# Week 2 # By John Stile ######################################################## # patching Solaris7 with recommended_patches # setup networking on solaris ######################################################## ######################################################## # Patching ######################################################## # create a place for our software patches mkdir -p /usr/local/src # this is where we will store our custom programs. cd /usr/local/src # Get on gregs server, and download patches. ftp 10.4.1.130 ftp> anonymous Passwd: bla@bla.com ftp> bin # make transfer binary ftp> cd pub # ftp> mget 7_x86_re.zip ftp> quit # now uncompress the file unzip 7_x86_re.zip # cd to the package directory # this is the solaris recomended patch cluster for I386 cd 7__x86_Recommended # Read the help file at least once in your life. more CLUSTER_README.TXT ## must have at least 10MB of free space on /, /usr, /var, /opt. ## patchadd command that saves the files to be replaced prior to patch. ## 1st it determins if there is enough disk space in /var/sadm/patch to save the objects to be replaced. ## Later refer to the "patchrm" man page ## "-nosave" when launching the patch script to avoid saving the backout. ## Each patch has a README file for special install instrucions. ## Diskless client root templates space need to be pathed before the server is patched. ## "showrev -p" to compare installed patches with the patch list in the culser. ## dont need to backout old pathces, but they will stay resident in /var/sadm/patch , and show up in showrev -p" # Install patches cd ./install_cluser ---or---- ./install_cluser -nosave # log file staved in /var/sadm/install_data/_log /usr/bin/showrev -p # to verify patches # Reboot to take effect reboot #-------------------------------------------------- # 106542 is the version of the kernel we are using. #-------------------------------------------------- ################################# # network stuff ################################# # Background of Solaris Network Setup # # These are the files that setup networking. /etc/hosts # sets the name to the ip /etc/hme0 # contains the name from /etc/hosts # the ip from /etc/hosts will be applied to hme0 interface ## for more than one ip on an interface, ## make a file /etc/hme0:1 containing a name from /etc/hosts /etc/resolv.conf # contains all your dns serer's ip's /etc/nsswitch.conf # sets the order of name resolution (host file, then dns) /etc/defaultrouter # sets your default gateway ## upon startup these files are read, and settings are made. # If you wanted to add ips manually, use route and ifconfig /sbin/route add -net default gw -p /sbin/ifconfig iprb0 -netmask ############################## # This is what we did in cass ############################## # create 3 files /etc/hosts /etc/resolv.conf domainname student.ohlone.cc.ca.us nameserver 10.4.5.65 nameserver 207.62.190.2 nameserver 4.2.2.1 /etc/nsswitch.conf #find the line: hosts: files dns /etc/defaultrouter 10.4.5.34 ################# #card is working ping 127.0.0.1 ping localhost # the card is plugged into the wall ping 10.4.1.212 # ping gateway ping 10.4.5.34 # ping a ip on the internet ping www.yahoo.com #nslookup to check nameresolution nslookup >sun.stilen.com >help #for help #### now check out your path to suff /sbin/traceroute 4.2.2.1