################################################### # Always make an ignite tape Put a tape in the tape slot make_recovery -AvC -t "Ignite tape for $(hostname) on $(date)" ################################################### # Create a new kernel # Start SAM, and create a new kernel. cd /stand/build # you will see vmunix_test, dlkm.vmunix_test, and system.SAM # SAM created kernel parameter file, but it can also be created # manually with these commands: # /usr/lbin/sysadm/system_prep -s system # vi system # #Build - this will create /stand/build/vmunix_test. # /usr/sbin/mk_kernel -s ./system # Save old 'system' and 'vmunix' mv /stand/system /stand/system.prev mv /stand/vmunix /stand/vmunix.prev # Move new system into place mv /stand/build/system /stand/system mv /stand/build/dlkm.vmunix_test /stand/dlkm.vmunix # Move new kernel into place # 10.x mv /stand/build/vmunix_test /stand/vmunix # 11.x kmupdate /stand/build/vmunix_test ##################################################### # New kernel will not boot, so must use backup 1.) Boot system, and hold down until you see "TERMINATING SELECTION PROCESS" 2.) BOOT PRI ISL Interact with ISL -> y 4.) At the 'ISL>' prompt, type: HPUX -is VMUNIX.PREV -or- HPUX (;0) /STAND/VMUNIX.PREV # HPUX10.x 5.) Rename the apropriate files (VMUNIX.PREV to VMUNIX) and rename apropriate files (SYSTEM.PREV to SYSTEM) 6.) Do a reboot # HPUX11.0 5.) kmupdate /stand/vmunix.prev 6.) copy /stand/system.prev /stand/system ##################################################### # Backup kernel will still not boot, so must restore from Ignite tape # This will over write vg00 1) Put in the ignite tape 2) shutdown -ry 0 3) Hold down until you see "TERMINATING SELECTION PROCESS" 4) menu choice: a 5) BOOT_admin> boot pri isl 6) interact with ipl? (yes) 4. /dev/rmt/0m #This restores data off tape over /dev/vg00 5. shutdown -yr0 # system should boot normally, if ignite tape is good. ##################################################### # Boot Process # Since you want to muck with the kenrel, # it is good to know the boot process Summery: BootRom->PDC->ISL->hpux utility->vmunix #-------------------------------------------------- The boot disk contains: a) A 2Mb "Boot Area," formated in "Logical Interchange Format" (LIF), and holds things: Initial System Loader (ISL) "AUTO" file HP-UX utility b) A HFS partition labled /stand, containing the kernel c) A HFS or JFS system root partiton ("/") d) A swap partition #-------------------------------------------------- 1) BootROM chip loads "Processor Depenedent Code" 2) PDC -> tests "Stable Storage" for boot disk hardware address -> runs the "Intitial System Loader" (ISL) 3) ISL reads AUTO file (for kernel load options), and runs HPUX utility 4) HPUX utility finds the root file system on boot disk, loads and runs the kenrel. 5) vmuix uses "init" to start the system. ##################################################### Summery: BootRom->PDC->ISL->hpux utility->vmunix